Free online Chess server. Play Chess now in a clean interface. No registration, no ads, no plugin required. Play Chess with the computer, friends or random opponents.
Play
Create a game Tournament Simultaneous exhibitions
Learn
Chess basics Puzzles Practice Coordinates Study Coaches
Watch
Lichess TV Current games Broadcasts (beta) Video library
Community
Players Teams Forum Questions & Answers
Tools
Analysis board Board editor Import game Advanced search
Sign in
Reconnecting
  1. Forum
  2. Lichess Feedback
  3. Simple request: Clicking on the Play button redirect to homepage

Hi, I noticed that clicking on the Play button no longer redirects to the homepage/lobby, but clicking on lichess.org logo does. Could we have the old behaviour back?

The play button is still a link to the lobby.

Thanks for checking, maybe this is a browser specific issue, I've tested this on 'Firefox Quantum 57.0.1 (64-bit)' running on Arch linux and 'Chrome Version 60.0.3112.113 (Official Build) (64-bit)'

The link works fine for me on Ubuntu 17.10 with Firefox 58.0b9 (Quantum is just new branding for 57+) and Chromium 62.0.3202.94

Oh that's weird, I don't know why mine is behaving differently. Just to make sure this isn't just my current machine, I tried this on my mobile browser too (with request desktop site), single and double clicks on the Play button both don't work there.

On Android (Firefox and Chrome) clicking didn't work, but pressing it for a second brought up the link open dialog. There was no such dialog in Safari, but 3D touching the button opened the link.

Something strange going on with my desktop browsers perhaps, I can right click to get the link options, but not left click on it to open the page.