lichess.org

Lichess connection problems - anybody else with the same problem?

Hi all,

just over the last few days, I've been getting the same message when I try to open Lichess. This is the message:

__________________
Secure Connection Failed

An error occurred during a connection to lichess.org. SSL received a record that exceeded the maximum permissible length. Error code: SSL_ERROR_RX_RECORD_TOO_LONG

The page you are trying to view cannot be shown because the authenticity of the received data could not be verified.
Please contact the website owners to inform them of this problem.
_____________________

There is a 'Try again' option and when I try again, I can get to the website ok.

It has also happened when I click on a game in the Lobby. I click on the game, then I get the same message, and when I try again, Lichess opens ok, not on the game itself, but with a notice that I already have a game in progress, which i can then get into no problem.

Is this a problem for anybody else, or is it an issue with settings on my own browser (Firefox)?

i cant even access from chrome even in private mode. when I log in.. it takes me to the page I was before trying to log in.. and when I try to access from edge each time I create a game, it starts with the pieces blindfold and when I reload they appear but my opponents abort before that

My connection is very slow and laggy since few days ago. Today I was disconnected three times. I've never experienced such a problem on Lichess. It looks like it's impossible to play blitz again...

P.S. I already tried to reset my router and factory data reset my tablet. Nothing helps.

This topic has been archived and can no longer be replied to.

Reconnecting