lichess.org

Configure Stockfish 10 WASM analisys

Hello.

Is there a way to configure the post-mortem analisys done by Stockfish 10 WASM? I like very much the feature to replay the whole game to catch my mistakes, or loose moves.

Both in Firefox, Chrome and Chromium, I observe that the depth ply count stops at 21/21, and the CPU usage also stops. Is there any limitation? I also have observed that it seems that it uses only 1 or at most 2 CPUs when my PC has 8 cores.

Because, the Stockfish WASM is run locally, not in cloud, isn't it?

I am in a Linux (Fedora) box.

Thanks in advance,

Yes you can configure the amount of CPUs and analyse as deep as you want, just click the menu on the bottom right corner of the analysis board.
There also used to be an option to change the hash table size but it has disappeared for me for some reason.

Oh, thank you very much for your fast and accurate answer.

OK, I have been able to set the infinite analisys... but I see no setting to configure the number of CPUs to be used. The Stockfish WASM here in Lichess is not multithreading?

There's also WASMX and PNACL, but I don't know how to change it. It seems Lichess sets it automatically depending on your computer.

Thank you very much. Will investigate...

@aturri I have Stockfish 10 64 BMI2 , but I think it works the same way: Go to Proberties of your engine and there you change under "Threads" to your maximum amount of cpus! Then change the value of "contempt" to 0 (Zero)! Hope that works! Let me know!

@odoaker2015 : In my "Stockfish 10+ WASM", going to the configuration menu, there is no "threads" setting. There is a "Múltiples líneas" (spanish, I guess it will be "Multiple lines", but that refers to the MultiPV option (to show the N-best lines).

Perhaps it depends on the Stockifish version Lichess choose "automatically" (at least I have not found any way to change it).

It seems BIM2 its a specific compile version of Stockfish where such "Bit Manipulation Instruction" instruction set is enabled at compilation time. As there is another with POPCNT enabled. So perhaps you configured, or Lichess some way figured out, where your local installation of Stockfish is.

Following that reasoning, perhaps my browsers do not detect my stockifih local installation path, and it "downloads" from the internet the javascript (or other internet technology) version of stockfish, which is shown as "Stockfish 10+ WASM". In fact stands for WebAssembly which is "is a binary instruction format for a stack-based virtual machine. Wasm is designed as a portable target for compilation of high-level languages like C/C++/Rust, enabling deployment on the web for client and server applications".

I think I installed stockfish locally on my Linux box. I am going to try to install it globally, or set the local path inside my $PATH, and perhaps Lichess.org will detect the local binary, and then the option settings are updated, matching my local version.

Bed time here, so I am not sure if I could check tonight, but will update if I have any news.

I have made stockfish available in the $PATH (making a simlink in /usr/bin/stockfish) but I only see the stockfish 10+ WASM on the browsers.
Don't know how to activate a different stockfish version :(

To enable WASMX:
- Firefox: Type about:config in address bar and set javascript.options.shared_memory to true (right-click → toggle)
- Chrome: Go to chrome://flags/#enable-webassembly-threads and enable

Reconnecting