lichess.org

Stockfish WASM engine never loads

When I visit a page and enable local analysis with Stockfish WASM, the engine never loads, and instead displays the "Loading engine..." message while looping the loading animation endlessly – even after 10 minutes of waiting.

https://i.imgur.com/oGTUDBO.png

I'm using these versions:

- Chrome v83.0.4103.14 (Official Build) beta (64-bit)
- macOS Mojave 10.14.6

In chrome's devtools console, I see this message when visiting lichess.org/analysis/RNB1QBNR/PPPKPPPP/8/3P4/3p4/8/ppp1pppp/rnbkqbnr_b_-_-_0_1 :

2rnbkqbnr_b_-_-_0_1:1 GET lichess.org/assets/_vb10K1/vendor/stockfish.js/stockfish.wasm.js net::ERR_FAILED

I don't know why the GET stockfish.wasm.js call is failing, I can visit the file directly without any problems. I've also tried completely clearing the cache, including the service workers in the devtools application tab, and it still doesn't work. The same problem also occurs in an incognito tab without any extensions.

Another forum post asked for the output of lichess.org/oops/diagnostics.html :

For a more readable version with syntax highlighting, see this github gist: gist.github.com/blackrobot/2ef1b98ea54b709a9036bb3abf74a201#file-02-devtools-error-txt

{
"diagnosticsVersion": 5,
"navigator": {
"userAgent": "Mozilla/5.0 (Macintosh; Intel Mac OS X 10_14_6) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/83.0.4103.14 Safari/537.36",
"platform": "MacIntel",
"chrome": true,
"is64Bit": true,
"hardwareConcurrency": 16,
"deviceMemory": 8
},
"wasm": {
"WebAssembly": "object",
"SharedArrayBuffer": "function",
"Atomics": "object",
"mvp": true,
"sharedMem": true,
"structuredCloning": "ok",
"growableMem": "ok"
},
"pnacl": {
"mimeType": true
},
"needsBoardHeightFix": false,
"hasTouchEvents": false,
"animate": "function",
"localStorage": {
"client-eval-enabled": "1",
"analyse.ceval.watchdog3.pnacl": "0",
"analyse.ceval.max-depth": "25",
"analyse.ceval.multipv": "2",
"analyse.ceval.threads": "7",
"analyse.ceval.hash-size": "256",
"analyse.ceval.infinite": "true",
"just-notified": null,
"push-subscribed": null,
"grid": "1",
"resize-nag": "1",
"speech.enabled": null,
"sound-volume": null,
"surl7": "socket1.lichess.org"
},
"serviceWorker": {
"navigator": true,
"permissions": true,
"Notification": true,
"PushManager": true,
"fetch": "function",
"Notification.permission": "default"
}
}

This topic has been archived and can no longer be replied to.

Reconnecting