Free online Chess server. Play Chess now in a clean interface. No registration, no ads, no plugin required. Play Chess with the computer, friends or random opponents.
Play
Create a game Tournament Simultaneous exhibitions
Learn
Chess basics Puzzles Practice Coordinates Study Coaches
Watch
Lichess TV Current games Streamers Broadcasts (beta) Video library
Community
Players Teams Forum Questions & Answers
Tools
Analysis board Opening explorer Board editor Import game Advanced search
Sign in
Reconnecting
  1. Forum
  2. Lichess Feedback
  3. New Mobile Version (Android)

Hi,
I noticed that other users has some feedback on the mobile version. I also feel like unfortunately the new mobile version was not much of an upgrade, I would prefer to use the old version, however adding the Studies is worth keeping it.
One thing I seem to notice, is that the resolution of the chess pieces seems to be more pixely on this new version. Anyone notice that?

Also pieces seems to be getting stuck when moving them, a la chess.com

what happends to me with this new app version it's that i cannot see when my friends are online.

Seems fine for me

+1

After update mobile app (android 5.1, meizu m3s) i can't play. Launch app, see first screen (loading screen - white papper and lichess logo - white hourse with black solid border)... i wait, wait, wait and nothing. Please, fix

6.0.1 is badly broken. I can confirm exact same problem as flashnot. It just locks up the screen and does nothing. Eventually I have to kill it with a taskmgr. Previous version worked. Not sure if it's possible to downgrade.

same here, doesn't load after the loading screen with knight after updating the app

Mine works now...I had to update my Androif software to the latest version.

mine works at 7.0

I downgraded lichess to 5.6.1 and it works. So the bug got introduced in 6.0.0 or 6.0.1. If you downgrade make sure you disable auto-update in the playstore so your working version doesn't get overwritten. Asking people to upgrade their OS is totally unreasonable so it seems the lichess Android developers forgot that their code needs to be multi-version Android not just the latest (7.0 aka Nougat).

This topic has been archived and can no longer be replied to.