lichess.org

[bug] My puzzles score appears to be malfunctioning?

The most recent point in my rating graph appear to be stuck. I observed this on desktop. There are two bugs I'm reporting, that I'm guessing are closely related.

== Rating graph bug ==
For example, if the points, left to right, on my rating graph were...
1100, 1110, 1120, 1130, 1125

After beating the next puzzle, the oldest point would be hidden (as expected), and then I expect the points in the graph to be...
1110, 1120, 1130, 1125, 1132
...but instead I see...
1110, 1120, 1130, 1132, 1125
The UI would show my rating as 1132, which is accurate, despite that the 1125 is stuck at the front of the graph. The front number stays stuck at the front of the graph.

== Rating "change feed" bug ==

Also, it seems like the relative adjustment to my score is displayed along the bottom of the board, and is updated as I complete each new puzzle, with the existing values sliding to the left, to make room for the new value.

Using the same example above, I'd see something like...
+10, +10, +10, -5

After beating the next puzzle, I'd expect...
+10, +10, -5, +7
...but instead I see...
+10, +10, +7, -5

The -5 will stay stuck at the front of the line as I complete more and more puzzles.

I uploaded a screenshot showing the problem. Notice how I failed the most recent puzzle, losing 8 rating points, but according to the chart, my score is going up, and supposedly I got +19 from the puzzle. As I complete more puzzles, the +19 stays in the last slot at the bottom of the board, and my graph always ends with a point at 1186, and new puzzle rating adjustments slide in the next to last spot. That's not the way the UI is meant to work, right?
imgur.com/a/sdXtn7m

How do I fix this?

Sure it is. The image is at the top of the page. It's just unfortunate that there's a bunch of other crap below the picture.

@Doofenshmirtz

What os/browser/device are you using? Are you playing only on desktop or also apps?

If you do all your puzzles on the browser, you will get a smooth graph, I think. At least puzzles on the mobile app are being rated promptly even though the graph and history isn't being updated.

@Doofenshmirtz Chrome on Linux, and also I play using the Android app.

@finlip I don't, unfortunately. I play from the mobile app primarily.

Is playing from multiple devices a known issue? Is there any way to fix the problem?

Try doing puzzles only on browser and not on mobile app and see.

You can't post in the forums yet. Play some games!

Reconnecting